Автор Тема: При создании нового письма из шаблона курсор не встаёт на свою позицию  (Прочитано 1571 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Ruslan

  • Новичок
  • *
  • Сообщений: 7
  • Репутация +0/-0
    • Просмотр профиля
При создании нового письма из шаблона курсор не встаёт на свою позицию - мигает в самом начале, а в тексте присутствует метка [CURSOR]
Версия LT крайняя - 7.3.8.1

Оффлайн Дмитрий Маслов

  • Администратор
  • Маэстро
  • *****
  • Сообщений: 6146
  • Репутация +220/-19
  • Я делаю мир таким!
    • Просмотр профиля
Спасибо за сигнал, поправим!

Оффлайн Piano_Dreamer

  • Активист
  • **
  • Сообщений: 58
  • Репутация +3/-0
  • "Потом" уже наступило. Начинайте дествовать!
    • Просмотр профиля
Проблема может быть в не верной расшифровке макросов. Подобные проблемы наблюдались и с другими макросами если начинаешь редактировать шаблоны. По умолчанию, если шаблоны не трогать, все вроде корректно работает.

Оффлайн Ruslan

  • Новичок
  • *
  • Сообщений: 7
  • Репутация +0/-0
    • Просмотр профиля
Проблема может быть в не верной расшифровке макросов. Подобные проблемы наблюдались и с другими макросами если начинаешь редактировать шаблоны. По умолчанию, если шаблоны не трогать, все вроде корректно работает.
Совершенно верно, только что проверил. Если только изменять текст, вроде работает, но когда меняешь шрифт, появляются ошибки при обработке шаблонов _cursor_ и _quote_.
Попутно выяснилось, что даже в случае нормальной обработки шаблона _cursor_ курсор становится на строку выше, чем в шаблоне письма, правда в самый её конец.
Ещё: при замене шрифта всего шаблона в пустых строках остаётся "Times New Roman"; это проявляется потом, когда начинаешь что-то писать в письме на основе этого шаблона.
« Последнее редактирование: 21 Марта 2012, 12:17:45 от Ruslan »